Случилось это с новым обновлением AJENTI. Дело в том что по дефолту они используют 1.10 версию NGINX. А она, как выяснилось, не поддерживает протокол 1.3. И сам демон при старте выдает ошибку. Так упали все сайты, что работали на Ajenti V.

Смотрите требования для 1.3 протокола:

Проблема выяснилась.

Теперь к решению:

Папка /var/lib/ajenti/plugins/vh-nginx в ней лежит шаблон генерации дефолтного конфига nginx_templates.py, в нем находим строчку:

ssl_protocols TLSv1 TLSv1.1 TLSv1.2 TLSv1.3;

и меняеем ее на эту

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

удаляем nginx_templates.pyс, если он есть и перезагружаем сервер. Затем перезагружаем сайты. Все, готово

Голосов  (1)
Плагин рейтинга создан автором этого блога. Буду очень признателен, если вы сможете его поддержать (ссылка)
Об авторе

Веб-разработчик. Работа с проектами простой и средней сложности. Верстка, программирование. Simpla, Drupal, Wordpress.

Смотреть посты